WPBakery issue with Wordpress 5.0


#1

As some of you might have already experienced, upgrading to WP 5.0 stops WPbakery Editor from working.

This is happening because WP 5.0 sets the default editor to newly created Block editor that comes with it.

To solve this issue, please Install this plugin https://wordpress.org/plugins/classic-editor/


Jupiter 6.1.6 Update Visual Composer Broken
Issues with latest wordpress update?
Learning from Demo Content
#2

#3

Omg, thanks so posting this! It worked. I logged into to my site and had no idea what happened, so appreciate the easy fix!


#4

You’re welcome :slight_smile:


#5

Yes; this is the solution for now. I found this way and this post confirms.

Thank you and kind regards,
Attila


#6

I also had a war with this issue. Now I found piece! :slight_smile: Big thanks!


#7

I have several issue with this solution…

Many pages do not load properly when re-saved
The page with add new elements does not close properly
Header of the page sections do not load properly

On the WPBakery site it say’s that the latest version is compatible with WP 5.0.
Also my version of Jupiter tries to update to the latest version of WP Bakery …
However i get errors when doing so…


#8

Works perfectly! Thanks a lot!


#9

I’m still having issues. The classic editor appears above the WPBakery section, so I can’t edit anything in WPBakery. My client needs some changes made to the site but I don’t want to screw it up. Any other suggestions?


#10

Can you show a screenshot of what you are trying to say?


#11

Hello, this is unfortunately not working for me.
Note that I am using WordPress in French, so you may see some elements of the enclosed screenshot in that language, but you will probably recognize where it is taken.
That screenshot is the one from a page I am trying to edit. That page is white and yet text is present (red lines under the words that only appear if I block-select). And I do not see how to access WPbakery as I could before the WP 5.0 upgrade.


#12

With the change I did as per your instructions…
33


#13

It seems like WPBakery is not even loading on the page.

Please go to WPBakery -> Role Manager and set the Post Types option to custom and then select the options in which you want to show the WPBakery Page Builder and then save changes.

Let me know if this works.


#14

Not sure where to find WPBakery. I do not see it on the left bar (see enclosed screenshot). Nor as a Plugin…


#15

It seems like the plugin is deactivated or not installed.
Did you ever use WPBakery Page Builder?


#16

I have installed WPBakery (had disappeared for some reason), but cannot activate it!
Can someone help? Not sure why version 5.6 being installed, it says that I should upgrade to version 5.0.1. I use the Jupiter theme


#17

Jupiter theme version: 2.07


#18

You are using the original version of WPBakery which is not compatible with the theme. The version that is compatible is the modified version and I am not sure how exactly this version got installed into your site.

This is a veryyyy old version of the theme. On one hand you are using the old version of the theme but on the other hand, you have updated the Wordpress and the plugins because of which the site is meant to fail. I suggest you set up a staging site and update your theme to the latest version which is 6.1.6. You can find the files in ThemeForest account from where you purchased the theme, please download the whole theme bundle and in the extracted files you will find Jupiter files.


#19

Hi @Danish_Iqbal

Facing the same issue with a client’s site.

Some other developer has installed Jupiter 4.4.1 [WPBakery Visual Composer (Artbees Modified Version) 4.7]. The client doesn’t have access to that developer or the theme file or the Envato purchase.

Our team recently moved the site to a new server and client reported this issue.

  • Tested the solution you’ve suggested above. Not working.
  • Tested rolling back WordPress to 4.9.9. Didn’t work.
  • Tested with Jupiter 6.1.6 found somewhere online (not sure where to get that file officially. Right now Artbees is selling Jupiter X). Didn’t work either.

Any idea what else can we try to fix this issue?


#20

The only solution is to update the whole site including the theme, wordpress and plugins.

First update the Wordpress to the latest version which currently is WP 5.0.3

Then, you will have to update to Jupiter 6.1.6 which you can find in the THemeForest. You will have to download the whole bundle/package and inside you will find the files for both Jupiter 6 and Jupiter X.

Or you can also find the 6.1.6 files from here https://themes.artbees.net/dashboard/releases/

After that, deactivate & delete the plugins that ship with the theme. The go to Jupiter -> Control Panel -> Required Plugins and activate them from here. This will activate the latest version of the plugins that are compatible with the theme versions.