WooCommerce Sidebar not showing up


#1

Aloha,
I’m having an issue with the WooCommerce not showing the Sidebar on both Product Archive Page and also the Single Product Page.

http://HawaiiAutoDetail.com/shop

I added the Categories and Filter Widgets to “WooCommerce Single Page & Shop Page”, however I do not see anything populating them so I removed it once again.

Please assist with this?
Thanks


#2

What you can do to troubleshoot this issue is:

1 - Make sure the Shop page is set correctly in Woocommerce > Settings > Products > Shop page.

2 - Make sure the sidebar is set correctly in Shop Customizer for the Shop page. It might be set automatically for category pages.

3 - Make sure in Appearance > Widgets the “Woocommerce Shop Widget Area”. is populated with some widgets.

4 - In case none of these worked fine, please kindly reset your Theme Options to the default and make sure the steps above are done. Remember to take a backup before this one, otherwise you might loose your theme options.

Regards


#3

I have this exact issue.

I already have reseted the theme properties and worked fine…until I import my settings back. Then, the problem reappears, so there’s a problem with the shop customizer.

What can we do to solve this?


#4

This simply means there is some setting that is hiding the sidebar.
You will have to check the settings one by one.


#5

hi. I have double check the settings for each page. Nothing is hiding it. As stated before, If I reset the parameters back to the defaults, the sidebar shows. Something’s wrong with the shop customizer.


#6

Okay, this might need some debugging.
Please log in to your Artbees account and start a new live chat with the support and explain your issue.

Thanks.


#7

Inconvenient setting of the product page. Faced the same problem. Until you create a separate rule for the store in the sidebar settings.
Though before exposed parameters on the page in Advanced Custom Fields position and the sidebar zero reaction.