White space above footer and between body


#1

there is a white bar between the site content and the footer. Ive tried removing padding and margin and nothing works. Can any body offer up ideas??


#2

In page settings did you try settings such as “Elementor canvas”?


#3

Setting the page to canvas seems to remove header (at least transparent overlapping header) as well.


#4

Im only trying to remove the white space above the footer. Jupiter used to be my favorite theme. I dont know why they changed it so much.


#5

It’s strange. Can you get in touch with the support so they can have a closer look?


#6

Same problem here…
When I select fixed footer, it goes behind a white bar from the body


#7

Does anybody have a fix for this? I know it can be removed because the demo sites do not have this white space.


#8

Did you change the page attribute to Default or Elementor templates? You should set it to Full Width in case you don’t have any sidebar on your page.


#9

that worked!!!

thank you!


#10

So switching the template works for me but then it omits the page title which I need, so if you want to fix with CSS, here is what worked for me - just add this to your custom CSS:

.jupiterx-main-content {padding: 0px;}

#11

Hi!

I have a similar problem, but the white space at the top of the content. When I add an overlap slider, a white bar on top of slider refuses to hide.


#12

Do you guys set the Page Attribute to “Full Width” while creating the page?

image


#13

for me, it was this setting that got rid of the top, left, right padding. However I am still unable to get rid of the white gap below the Revolution Slider Widget. ??? Any clues on how to get rid of that?


#14

I am afraid, that there is not this “ONE” solution, because such effects occures as explained in previous comments due to various settings on different places and due to cascading effects on css styles you sometimes get crazy. So what I would recommend (depending on your analytic capabilities)
(1) check the page settings outside of elementor editor: fullwidth, no sidebar layout,
(2) check your header and footer templates (do they have special margins, paddings, etc.) - it may also come from here
(3) check every compents for fullwidth (most likely only for left and right spaces), margins and padding
(4) use chromes developer view - you can adjust css parameter online and may get an idea, from where the unwanted effect comes :slight_smile:

what i experienced: the template importing mechanism seems to be a bit tricky, because it may damage and confuse the elementor editor after you imported a whole page template for example and of course it depends also on the template specifics.

so long story short: you may be lucky to hack the right setting with one shot, but you will learn much more if you go through each possible settings and learn their impact - but again: dont get crazy if a setting is not working as expected - it could be sometimes also a but

have fun.


#15

Thanks Mohsen, that worked for me!