VC Post Grid loading problems with cache usage


I have posted this problem many times and each time I’ve been told by jupiter that it is the VC plugin problem.

So last week I decided to narrow this problem down.

The problem with post grids when used with a cache plugin is that after 24 hours the post grid will not display the content.

I set up a clean wordpress website using wordpresses default theme. (not jupiter).

I bought a copy of visual composer and created a page using a post grid

I installed my usual cache plugin.


So now we know its NOT JUPITERS FAULT. I tried different cache plugins. Same problem. So I can safely say that it is Visual Composers problem so have raised a ticket with them.

My question now is what can I use as a replacement in jupiters theme to do the same job as the Post Grid??

Hope this helps anyone else facing this problem



I’m having this same issue, which is very frustrating. No one wants a broken site. Especially clients who are using the blog heavily and seeing this happen. Looks bad on me, looks bad on Jupiter. I even have turned the server side cache off and I’m still getting blog breakage. Not only the grid posts but any blog posts for that matter.

This is ridiculous


For me the post grids work if I disable any cache plugin.

its definitly problem with the VC plugin. Its a shame because the post grids are really useful and easy for the clients to use.

Also this is really easy for Jupiter developers to check for themselves. Yes they can say that its a problem with visual composer but as they are using it as a main functionality for their theme the least they can do is acknowledge the problem and speak to VC to try and work out a solution for their clients.


Can you let me know what VC says in response to this? Saw you had opened a ticket with them about it. Really wanna figure this out.


I’ll post my response here. They said they will look into it but its been 3 days now.


This is what I received from artbees, Just excluded these from cache so I’ll let you know if this works for me, fingers crossed!

"Please disable cache plugin or server cache and check will this happen again. You should exclude the folder below and the files in it from cache:



These files are dynamic and can change when you add a new shortcode or change option in theme options. if so you should always clear plugin cache."


Visual composer Post grid with cache bug.

Just to let everyone know that if you use use a cache plugin with visual composer your post grids will fail after a day or so. The only way to avoid is clear your cache every day. But of course this is not a solution. Visual composer developers have said they will look at the issue but a fix will probably only appear in the next update (march I think). Anyway Emre from WP Fastest cache kindly looked into the matter and has updated his cache plugin to fix the problem. details here So if you need to use a cache plugin for now only **WP Fastest cache** will work with visual composer post grids


Hi I’m using this plugin but the problem remains. Has anyone reach a solution?


Hi @Miguel_Proenca

I would report this issue to our developer and if they find any fix for that we would inform you in the thread.

Best regards,
Artbees Support


Hi Pankaj thank you for the quick reply.

The solution is easy: create a code to place in Wordpress to automatically purge the cache every 24 hours. Can you help us with that?

Best Regards


It’s 2018 and this problem still has not been fixed. Why, Artbees?

I’ve tried using the WP Fastest Cache plugin “fix” but that didn’t work.

One of the developers of Visual Composer posted a snippet that fixes the problem but again, that didn’t work for me.

I really need to use the Post Grid element on my page. What else can I do to fix this problem?


Would be helpfull… please!!