Turn Off Theme Cache


#1

With the newest update to Jupiter 5, the theme cacheing “feature” is a nightmare. Every single time I make a change or navigate to another page when I am working on the site from the backend I have to clear the theme cache to see my change that took effect. Cumulatively this will create hours of wasted time, especially when we are making big changes to the site. I am requesting that you can turn off this feature.


#2

I second this.

In addition, how does the cache work? Is it meant to boost performance? If so, that could be a serious issues for many users.

Managed Wordpress hosting often features a built in cache (mine uses Varnish; others are similar). Most such services disable third-party cache plugins due to conflicts with the hardware caching built into the host.

If Jupiter uses the theme cache to improve performance, there might be potentially serious issues for those of us using managed Wordpress accounts. If this is the case, users should have the option to disable the cache, or Artbees should include a prominent disclaimer about conflicts in their documentation and on Themeforest.

If this isn’t the case, it would still be nice to have the option to disable the cache. It’s frustrating to have to constantly clear the cache.


#3

Please consider that the clear Theme Cache functionality can not be canceled as it needs to be there to make the system understand any probable changes that may be in future updates. Unfortunately there is no escape about this.

Thank you for your understanding.


#4

I third this.

I run managed Wordpress which already has built in cache clearing functions and they don’t seem to play nice with the Artbees version. We have lots of issues with icon boxes and content boxes not working properly as well as other features. We have clients calling daily telling us parts of the site doesn’t work and we have to login and repeatedly clear cache to get functionality back and then it doesn’t hold.

I will probably have to downgrade back to Version 4 which is unfortunate.


#5

I also have a managed Wordpress account which had some conflicts. To date, these seem to have been resolved, as have the conflicts with Jetpack.

The only thing I changed was the “Query String From Static Flies” option under the Advanced/Manage Theme menu, which I had previously disabled. Enabling the setting resolved the problems.

There’s also an option to Disable Dynamic Assets on the same page (last item).

Your mileage may vary, so good luck.


#6

Please, disable the cache and also the top black admin menu button.
Thanks.


#7

your cache system is a nightmare, when cache is cleared or changes are made, css and js are first inside the html then going from one page to another jupiter rebuilds the three following files : components-production.min.css, components-production.min.js, theme-options-production.css

The thing is browser caches thoses incomplete files, so you end up with a broken site everytime you make changes… horrible… when you make a change, you have to navigate on every page so that jupiter rebuilds the assets files, then completely clear the browser cache…

I really like jupiter (i have used it on 3 websites) BUT I’ve worked with around 30 different themes and jupiter is the only one being so annoying … a real nightmare

i will not use jupiter again because of this

You should at least offer a way to force the browser to redownload the assets files (by changing the version number)

uploads/mk_assets/components-production.min.css?ver=2a3bf0940604521ac5d27d530dd2a24d

everytime there is a change…


#8

I want to see this gone too. I never had problems with the theme but since the Jupiter 5 release it has been nothing but a headache and a website on which I based this theme now probably needs to be migrated to another framework.


#9

Yes, I’m also experiencing these exact same problems.

I never had these issues before with Jupiter 4, and my development/page creation/styling process time has actually doubled as a direct cause of this issue.

Please find some way to fix this - I’ve been a huge fan of Jupiter for a long time, and have recommended it to many other developers and want to continue to do so.


#10

Hello,

Do you still have any issues when you enable this option ?


#11

This issue should be solved if you enabled this option:

In fact it does exactly what you are saying.

It updates query strings when there is a change.


#12

I have the same problem as Laura and nitrix-ud. After changing on a page and clearing Theme Cache pages loads normal. After another loading the same page styles are broken.

  • Titles are in wrong font styles.
  • mk-charts stops animating.

After cleaning Theme Cache again, it loads for the first time as it should be. After reloading page the style is broken again. Help, please! :frowning:


#14

Please open a ticket with your hosting and wp-admin information for getting help from support team:

https://artbees.net/themes/dashboard/new-ticket


#15

I too am not a fan of the auto cache. It really messes with my site and creates havoc for the user base. We really should be able to toggle this function. This automatic cache alone could be the reason I stop using Jupiter, which is sad, because it has been such a great theme.


#16

This is theme caching is completely UNNECESSARY and is only causing more damage than solving a problem…


#17

Hello, we have the same issue and Artbees support didn’t help us on that. Can you tell me how did you fixe this issue? It’s a really pain for us. Many thanks


#19

We open a ticket 37592 but they didn’t fixe the issue. Could you help us on it? Many thanks
We open a ticket 37592 but they didn’t fixe the issue. Could you help us on it? Many thanks


#20

Hello Micheal,

With the new release we have an option called intelligent dynamic components, if you disable it you will be able to use your theme without dynamic components.

And also for the dynamic components, we have hooks for cache plug-ins and it works much more smoother than before :slight_smile:


#21

Unfortunately the issues are still present for me as well.

After a while the margins disappear, the fonts are wrong, allign adjustments are gone until I reset the cache again.

Isnt there a way to automatically reset the cache every minute or so?


#22

Are you using child theme or did you customized jupiter ? Could you please open a ticket and let us investigate this issue.