The Event Calendar Conflict with JupiterX Compiler


#1

I have figured out that Jupiter X is conflicting with “The Event Calendar”. When I disable the calendar everything works/loads as it should.

The theme generates these two files but when you do a cache flush/force reload, the following files come back as a 404 and the site loads broken.
/wp-content/uploads/jupiterx/compiler/jupiterx/script.js
/wp-content/uploads/jupiterx/compiler/jupiterx/style.css

https://npowerorgstage.wpengine.com/

After you click around the site for a bit, the files will work or generate so the issue is intermittent in that it sort of fixes itself.

Does anyone have any thoughts on this conflict that is happening? At this time both JupiterX and The Event Calendar support teams say this is out of scope.


#2

In my case this type of error has gone disabling JupiterX config option Development Mode (In Jupiter X -> Control Panel -> Settings)… There is some sort of problem with this option that must be fixed.


#3

Damm… The problem persists… Sorry…


#4

Yeah I check my setup and I had that turned off as well. At this time, I am not using The Event Calendar. I am running JupitorX 1.2. What version are you?


#5

Last version… yet figuring out how to solve that problem… In my case, I have a form that, when sent, creates a new post and redirects the user to that new post created. At first load, the css fires 404 error, reloading the page, the css loads.


#6

Did one of you manage to find a solution to this issue in the meantime?

I have the same issue, but with another plugin: GeoDirectory.
In my case, on some pages (related to GeoDirectory, like the create listing and listing preview page), the same files ("/wp-content/uploads/jupiterx/compiler/jupiterx/script.js" and “/wp-content/uploads/jupiterx/compiler/jupiterx/style.css”) return a 404 error and the layout is broken.
On page refresh the problem disappears (and by clicking on the URL of the file in the error message, then “Open in new tab”, the CSS/JS file loads correctly), but inserting a message for the users that specifies “Reload page in case of layout issues” would be a very bad service… :wink:

Thank you in advance for your feedback.