The Content Area Was Not Found in Your Page


#1

Can’t create/edit pages or posts with Elementor. I have deactivated all the other plugins except Elementor & JupiterX Core but still not working.

Getting following errors

  1. “Sorry, the content area was not found in your page. You must call the_content function in the current template, in order for Elementor to work on this page.” **_

  2. Read More function is not working, neither with Jupiter nor with the native WP editor**_

  3. Read More button won’t appear on the archive page**_

  4. The actual post page only shows excerpt, not the full article**_

Need urgent help


#2
  1. For this issue, have you added excerpt to the page? Or does it even happen when you try to create a new page?

  2. How exactly are you trying to add the Read More?

  3. Yes, that is a known issue and will be fixed in the future.

  4. Have you added excerpt to the post? If yes, try removing it?


#3

I removed excerpt and this is what’s happening now

  • Read more button works on archive
  • The full post content is visible on single post
  • I added the Read More break from native WP editor

BUT HERE IS THE REAL ISSUE

  • The “Read More” only works with native WP editor, as soon as I switched to Elementor (without excerpt) the “Read More” stopped working
  • As the result, the blog archive page shows the entire blog instead of small portion of control & “Read More”

In an ideal case

  • The Elementor editor should work for all the new & old posts/pages
  • The posts should work with manual excerpt
  • The “Read More” button should work with Elementor
  • The blog archive page should not show full article if “Read More” OR manual excerpt is used

These are standard function across all the WP themes & frameworks I have used, including the legacy Jupiter version, not sure why can’t we have it here as well.

Looks like a lot of bug in Jupiter X that needs to be removed.


#4

Yes, you are right and we are aware of these issues.
These issues will be fixed soon in coming updates.


#5

Any update on this? I want to create posts using Elementor but it’s not working.

It’s really frustrating to see such basic & most essential function missing from the theme.

When do we expect the update with the above issues fixed?


#6

Well, you can create the posts using the POST element that comes with the Raven. There is no issue with showing the posts. The issue is with excerpt and the read more buttons.

As of now, I do not have an ETA but the issues will be fixed in the future updates.


#7

This is nuts. Plugins with elementor always crash from what i’m seeing. Plugin authors seem to have a tough time keeping up with recent elementor changes and always causes issues on sites. My whole site crashed because of Raven.


#8

Yes, unfortunately, it was very worst situation to be in but hopefully, it won’t repeat in the future.
I also suggest not to update the plugin immediately. Always wait for few days before you update the plugin or the theme and in the meanwhile search the forums for any bugs related to that new update.


#9

After updating Reven (1.0.4) & Elementor (2.4.2) it looks like the issue solved.

Testing a few things before coming to a final conclusion.


#10

I’m glad it’s resolved for you.