ROW ID not showing correctly in frontend in Jupiter 6.1.3


#1

Problem:
ROW ID not showing correctly in frontend in Jupiter 6.1.3

Affected Versions:
Jupiter 6.1.3
WPBakery Page Builder 5.4.8

How to solve:

For VC ROW

  1. Please edit vc_row.php file present in jupiter/components/shortcodes/vc_row folder.

  2. Go to line 13 and you will see the below line of code:

$id = ! empty( $id ) ? (' id="' . esc_attr( $id ) . '"') : '';

Replace the code with the below:

$id = ! empty( $id ) ? (' id="' . $id . '"') : '';

  1. Now, scroll down to line 97 and you will see the below line of code:

<div <?php echo esc_attr( $id ); ?> <?php echo implode( ' ', $wrapper_attributes ); ?> class="wpb_row vc_row vc_row-fluid <?php echo esc_attr( implode( ' ', $row_classes ) ); ?>">

Replace the code with the below:

<div <?php echo $id; ?> <?php echo implode( ' ', $wrapper_attributes ); ?> class="wpb_row vc_row vc_row-fluid <?php echo esc_attr( implode( ' ', $row_classes ) ); ?>">

For VC INNER ROW

  1. Please edit vc_row_inner.php file present in jupiter/components/shortcodes/vc_row_inner folder.

  2. Go to line 26 and you will see the below code:

<div<?php echo esc_attr( $id ); ?> class="wpb_row vc_inner vc_row vc_row-fluid <?php echo esc_attr( implode( ' ', $row_classes ) ); ?>">

Replace the code with below:

<div<?php echo $id; ?> class="wpb_row vc_inner vc_row vc_row-fluid <?php echo esc_attr( implode( ' ', $row_classes ) ); ?>">

That’s it…!

Purge the plugin cache (If using any cache plugin)
Clear the browser cache and voila…!

Permanent Fix:
The permanent fix of this issue will be released in the next theme update.


Row ID has double quotes in 6.1.3
#2

#3

It was my fault it works for me


#4

Hello,

Could you share your site URL?

Thanks.


#5

The same bug is in vc_row_inner.php

jupiter/components/shortcodes/vc_row_inner

On line 26 replace with:
<div<?php echo $id; ?> class="wpb_row vc_inner vc_row vc_row-fluid <?php echo esc_attr( implode( ' ', $row_classes ) ); ?>">


#6

Thank you for observing that. :slightly_smiling_face:

I will update the article.


rowID Issues | media queries and anchor-links broken
#7

Hi, any ideas when the update will be out?
really not in mood to change any files in multiple websites. (:


#8

Hello,

Sorry, but for now we don’t have the exact date of the new theme version.
That’s why we provided this workaround. Please edit the files as described above to fix the issue.

Thank you for understanding.
Best regards,
Artbees Support.


#9

Could I insert an anchor link in a button and use the anchor ID in a row?


#10

Hello,

Yes, you can do this.

Best regards,
Artbees Support.


#11

Unable to link to Row ID in 6.1.4