Responsive Images - Background layer (bug maybe)


#1

Hey guys,

I have just noticed this… I am using the latest version, but it’s probably been the case forever. Ticking responsive images in theme options, is probably good practice for most websites, but I have just noticed that it also effects backgrounds. Once it goes into mobile mode, it selects a smaller background image which of course is then stretched out and looks pixelated.

I guess this occurs only when “cover” whole background is selected also in the page section.

Not sure if this is a bug… or even fixable. I would say that it could probably be a good idea for you to make it that background images arent effected by the responsive image option?

But for now, my fix was just to turn off responsive images.

Cheers


#2

Any update on this? Is it a known bug…


#3

I’ve already asked about this. In order to keep the full large image as background you need to turn off “responsive images”. That is not the answer i wanted to hear either but thats what they said.

They said to “You should make use of Background Image (Portrait) option in Page Section setings.” but this was not a 100% fix.

There’s gotta be a way to disable for Background images all together, maybe even assign a css class and override their code that way.