Raven breaking Elementor


#1

So after building a simple marketing site (one page) last week, I went back to edit it yesterday and Elementor was no longer working properly.

I can edit the header with Elementor no problem. However when I try to edit the page itself, the Elementor editor doesn’t load. It does tell me to try safe mode, at which point it says that theme files are missing (I’m on Jupiter X 1.6, and had no issues last week).

Oddly enough, if I disable the Raven plugin, I’m no longer able to edit the header with Elementor, but I CAN edit the main page… though without all kinds of Raven elements that I’d used to build the page.

So it seems like Raven is the problem. Or could it be something else?


#2

Raven is also causing my editor to not load.


#3

See if clearing the browser cache or better yet, using different browser helps. That solved the issue for me, however, I’m still not sure why this is happening. If this doesn’t help check out this article


#4

Tried it in another browser, still no success. I’ve also increased my memory limit to 256M, no luck there.


#5

Same problem here, related to Raven.

The Elementor side widget will not load, just has a spinning hour glass.

Disabling Raven fixes the issue.

Please update ASAP… need raven and need Elementor to work!


#6

Have you tried the solution described here at the bottom of the page?

Jet Plugins

The only known issue with the Jet Plugins is that the as soon as Jet Elements, Jet Tricks and other Jet plugins are active alongside with Raven and Elementor, it doesn’t stop the spinner on the Elementor editor loading. So it won’t be usable if you face this issue. To fix this problem, simply add this to your .htaccess file or ask your web host support to do it for you:

Also, Make sure you already have proper server resources as mentioned in this article.

<IfModule mod_substitute.c>
SubstituteMaxLineLength 20M
</IfModule>

#7

This issue has been fixed in the chat support.

For the rest, this was happening because in the menu item, he had added a hash URL “#2018”. The issue is somehow happening because of the number being used. Changing it to some string like “twentyeighteen” fixed the issue.


#8

Could you please explain more about the issue?


#9

I think it is because of the low memory issue.

Could you please go to Jupiter X -> Control Panel -> System Status and tell me the values for WP Memory Limit and PHP Memory Limit?


#10

The Elementor editor is unusable, it constantly shows a spinning wheel and will not load. I debugged and found it did not work until I disabled the Raven plugin


#11

I also checked my memory, here are the values:

WP Memory Limit: 40 MB
PHP Memory Limit: 128 MB


#12

Same problem with the Elementor editor not loading (spinning wheel) when Raven is activated. Any resolution on this yet?


#13

I’ve been having a very similar problem and have asked Artbees to confirm whether or not there is a conflict between Raven and Elementor.

My Config
Jupiter X 1.10.0
Raven 1.5.0
Elementor Pro 2.6.4

I have created 4 Raven Post elements on my home page - all with extensive CSS customization - custom created 1 element and copied to the other 3.

Now I can’t edit them.

  • for 3 of the post elements, the Elementor settings panel is just blank.
  • for 1 element, I can see the first tab (content), but clicking on Style and Advanced tabs does nothing.

Does anyone have any ideas?


#14

Update…

I upgraded PHP from 7.0 to 7.3 and that seems to have resolved the issue. Haven’t tested anything in between.


#15

My customer has a new site that was built with a licensed version of Jupiterx Pro and Elementor pro.

I need to support them as they no longer do business with the company that designed/built the site.

There is a CLEAR BUG in the Raven Pro module preventing it from being edited after it is created. This just recently broke in the past month or so.

I can recreate the section using Raven but after exiting and going back in – I cannot edit the section any longer. Just a blank white panel on the left when I select the section I wish to edit. For the record - it is a POST SECTION that I am trying to edit.

I tried all the solutions to no avail.