Polylang destroys child theme and theme settings


#1

Any theme settings I did, are missing since I created two new languages with polylang plugin. (Only installing and activating polylang didn’t make any harm to the site.)
Interesting: When I deactivate the plugin everything is fine again.

After some research I assume that I have to set up the theme settings for each language itself. Or unify the theme settings for different languages.
Am I right? And if so, is there a trick to take along the current settings and use it for both the new languages?

Header Builder and Polylang:
Something worries me as well: While having polylang activated and languages set up, I tried to activate my custom header, I created via the header builder. That didn’t work out.
As well: polylang creates a language switcher along with a second header above my menu header.
Could it be that thats the reason why my custom header wont work any more with polylang?
And how can I get rid of the default language switcher in the second header?


#2

Hello,

Please go to Settings > General and activate the option “Unify Theme Options” at the bottom.
This way your settings will apply to both languages.

As for the header, you need create a separate a header for each language in the header builder and select the needed header for each page in the page editor in Jupiter Styling Options section.

Thank you.
Best regards,
Artbees Support.


#3

Thank you very much! I’ll try that.

One more question: In your instructions “Setting up a Multilingual Website with the Polylang Plugin” it is said:
Note: You should also translate the theme to your other languages. You can find a guide for that in this article. Please note that .po/.mo files should be created manually for each language.”

That surprised me. I am not sure: Do I have to do that or will it work even without translating the theme maybe? If not: Why do I have to translate the theme as well?
Maybe it would be helpful for future users like me to explain that shortly furthermore within these instructions.

I opened a new topic for that question: http://forums.artbees.net/t/why-do-i-have-to-translate-the-theme/13993


#4

You’re welcome.
I’ve replied to your other topic.

Please check.

Best regards,
Artbees Support.


#5

As for the header, you need create a separate a header for each language in the header builder and select the needed header for each page in the page editor in Jupiter Styling Options section.

Where can I choose the header? Can’t find the right setting.


#6

I found it already.
If you check “override global settings” you get more settings below…


#7

That’s great.

Best regards,
Artbees Support.