Polylang crashes my site


#1

Hi!
I am having many problems with Polylang, for some reason the website crashes every time I add a 2nd language or add some CSS on the customizer for example.
I am using the child theme, and I work on a local environment with MAMP. The only way of getting it back to work is by cleaning the database.

Here is the log I get from WP_DEBUG if it helps

Fatal error: Uncaught Error: Call to undefined function add_settings_error() in /Applications/MAMP/htdocs/FootballXP/wp-content/plugins/polylang/admin/admin-static-pages.php:149 Stack trace: #0 /Applications/MAMP/htdocs/FootballXP/wp-includes/class-wp-hook.php(288): PLL_Admin_Static_Pages->update_page_on_front(‘23’, ‘23’) #1 /Applications/MAMP/htdocs/FootballXP/wp-includes/plugin.php(203): WP_Hook->apply_filters(23, Array) #2 /Applications/MAMP/htdocs/FootballXP/wp-includes/option.php(312): apply_filters(‘pre_update_opti…’, 23, ‘23’, ‘page_on_front’) #3 /Applications/MAMP/htdocs/FootballXP/wp-content/themes/jupiterx/lib/api/customizer/classes/class-multilingual.php(260): update_option(‘page_on_front’, 23) #4 /Applications/MAMP/htdocs/FootballXP/wp-includes/class-wp-hook.php(286): JupiterX\Customizer\Multilingual\CustomizerMultilingual::load_settings(’’) #5 /Applications/MAMP/htdocs/FootballXP/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #6 /Applications/MAMP/htdocs/FootballXP/wp-includes/plugi in /Applications/MAMP/htdocs/FootballXP/wp-content/plugins/polylang/admin/admin-static-pages.php on line 149

Thank you!
Best regards,
David


#2

It seems like the function add_settings_error is missing which is being called by the plugin.

Have you installed the plugin completely? Can you try to re-install the plugin?

Are you using any cache plugin?


#3

Thanks for your answer.
No, I’m not using any cache plugin, and I’ve installed it through the ‘add plugin’ section from WordPress, so I guess it is installed completely.
Now I tried deleting Polylang, cleaning the folder “languages” from wp-content, flushing the cache and re-installing it by uploading the zip file, and the issue is still the same…
When I found this problem the first time I thought it was because I previously tried another plugin, but then I decided to do a fresh install of wordpress and the theme to test it, and the issue was the same.


#4

Okay, I understand.

Which cache are you talking about? Plugin cache?


#5

The cache flush that you have on the theme settings. (on the Jupiter X tab)
I tried yesterday on a live site from a fresh install and seems to work, but I had very little time to test and didn’t use the child theme. Do you have any idea why not on localhost? Since I would prefer to work local.


#6

Ok, after some more testing, I saw that it also crashes the live site… for English and Spanish seemed to work well, but the moment I added Chinese for example, the problem started again. I’m able to access the site, but not the wp-admin, which shows error 500 and my only solution so far has been to clean the database by searching and removing the zh_cn


#7

This is very strange and needs more investigation.
Please log into your Artbees account and start a live chat and explain your issue.