Jupiter X 1.12 with Raven and Elementor no longer works with Wordpress 5.3


#1

Sorry, Jupiter X is broken (Raven specifically). Brand new install, including Wordpress 5.3. Installed the Minerva demo theme. Tried to edit a page, and Elementor won’t load (it does in Safe Mode). After disabling Raven, Elementor loads.

Getting this error:

Declaration of Raven\Modules\Nav_Menu\Classes\Walker_Nav_Menu::walk($elements, $max_depth) should be compatible with Walker::walk($elements, $max_depth, …$args) in /home/public_html/wp-content/plugins/raven/includes/modules/nav-menu/classes/walker-nav-menu.php on line 390

Been using Jupiter for years, but each version is becoming more and more unstable. Am considering to finally walk away from it, unfortunately.


#2

Same problem here :frowning:

Well i think Artbees have problems cuase are new on “elementor” enviroment with new version Jupiter become more stable… Relax, they are on version 1.12 :wink:

The last version was 6.x


#3

hi guys, yes the issue is confirmed and we are working on it to fix it as soon as possible. Thanks for reporting


#4

Thank you for the quick reply! In the meantime, I will downgrade Wordpress. Will keep looking out for Jupiter 1.13.


#5

Guys you may use this patch to fix the Raven compatibility issue with WP 5.3 and be able to work with Elementor again:

Just simply upload it to your wp-content/plugins/ folder, extract the zip file and merge the existing files. Remember that it should be only and only Raven 1.7 and WP 5.3. The official fix is on the way.


#7

The patch does not seem to work for me. Is the update to Raven coming soon?


#8

Thanks @Mohsen_Rabieai! The Raven patch/merge worked to get the Elementor Editor back in. Heads up that we’re seeing some jet issues after the WP5.3 upgrade as well. Jet Parallax for sections is losing the image when it’s viewed on the front end. You can see the image in the Elementor editor, just not on the final page. Inspector console is showing this error:

Uncaught TypeError: Cannot read property ‘indexOf’ of undefined
at elementorColumn (jet-tricks-frontend.min.js:6)
at _runHook (frontend.min.js:2)
at Object.doAction (frontend.min.js:2)
at e.exports.runReadyTrigger (frontend.min.js:2)
at HTMLDivElement. (frontend.min.js:2)
at Function.each (jquery.js:2)
at a.fn.init.each (jquery.js:2)
at _default.runElementsHandlers (frontend.min.js:2)
at _default.onInit (frontend.min.js:2)
at _default.Module.trigger (frontend-modules.min.js:2)


#9

Yes, but this patch will also work if you make sure the JS files are not loading from the browser cache anymore. Clear your browser cache and try again.


#10

Great… the quick patch worked, but I can’t edit any page because Elementor won’t load.


#11

Elementor seems to work again after updating Raven plugin to the newest version.


#12

Run. Don’t walk. The lack of QA in the release process is just inexcusable.


#13

Also made a mess of my elementor templates


#14

Has anyone found a way to remove the “Declaration of Raven\Modules\Nav_Menu\Classes\Walker_Nav_Menu::walk($elements, $max_depth)…” from the header?

It looks so unprofessional :tired_face:

The patch also didn’t work for me…


#15

Kay, I would recommend downgrading Wordpress until this is fixed. There is a plugin called WP Downgrade that allows you to reset Wordpress to the earlier version and then everything will work ok again as it did before. i did this and its all back to full functionaility.


#16

It’s fixed now. This topic can be closed.


#17

Oddly, it’s still breaking my site after updating core, theme and wordpress. If I update Raven to 1.8.1, the site crashes. If I leave 1.7 and update wordpress i can’t edit with elementor.


#18

Not for me. I did a fresh install with the latest version (1.13) and all seemed to be fine. Was even able to install a demo project without issue.


#19

Would you please send over your WP and FTP credentials in private? I can check and let you know what is wrong.


#20

It must have been on my end, tested again on test site, and now live on active site. All is working. Thanks!


#21

Glad to hear that :slight_smile: