Jupiter Theme - Fatal Error


#1

Hi guys. Having trouble with my current Jupiter 4.1.1 theme. When I try to edit a page integrated Visual composer doesn’t work anymore. Nor I can access the Theme options. I get the following error.
“Fatal error: Uncaught Error: Function name must be a string in /www/htdocs/w01346c8/frankenmetalle.com/wp-content/themes/jupiter/framework/admin/generators/option-generator.php:80 Stack trace: #0 /www/htdocs/w01346c8/frankenmetalle.com/wp-content/themes/jupiter/framework/admin/generators/option-generator.php(9): mkOptionGenerator->render() #1 /www/htdocs/w01346c8/frankenmetalle.com/wp-content/themes/jupiter/functions.php(260): mkOptionGenerator->__construct(‘Jupiter_options’, Array) #2 /www/htdocs/w01346c8/frankenmetalle.com/wp-includes/class-wp-hook.php(286): Theme->_load_option_page(’’) #3 /www/htdocs/w01346c8/frankenmetalle.com/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(’’, Array) #4 /www/htdocs/w01346c8/frankenmetalle.com/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #5 /www/htdocs/w01346c8/frankenmetalle.com/wp-admin/admin.php(224): do_action(‘toplevel_page_m…’) #6 {main} thrown in /www/htdocs/w01346c8/frankenmetalle.com/wp-content/themes/jupiter/framework/admin/generators/option-generator.php on line 80”

I am in a bad situation as I got the page from previous service provider and have no information or access details. Therefore I can’ conatc artbees support at the moment.
At the moment there are two Jupiter Versions installed ( 4.1.1 and 6.1.2 ). Should I first try to activate the newer one or is this a bad idea ? I am afraid from crashing page totally if I do so.
Maybe someone can give me a hint of what to do.
Thank you

Chris


#2

One more thing to ask. Should I upgrade wordpress to version 5.2 or does this Theme not support this version of Wordpress?

Thank you