How To Remove MK-Blog Hover Icon


#1

This is one of the most frustrating features of the Jupiter theme. For the life of me I cannot find how to remove the icon that shows on mk-blog when you hover over a feature image.

Please tell me how to remove this.


#2

Wondering why this hasn’t been answered yet? It should be a pretty easy fix I’m guessing.


#3

I used to be able to swap it out using CSS, but now that the theme is using SVGs, I think it requires changing the actual template code. I wish there was an easy way to change them in the theme settings or something, because the icons they use by default do not suit me either. At this point, I was only able to hide them,


#4

I don’t mind hiding them…can you let me know how you did it? I’m decent with changing the coding and have tried to in many spots with no success.


#5

You can add some CSS to the Custom CSS in the theme options. Basically, add the following. This will remove all images over the posts regardless of type (i.e. image, audio, quote, etc.)

.post-type-badge { display: none; }

OR if that doesn’t work,
.post-type-badge { display: none !important; }


#6

P.S. Actually changing the icon now requires you to go into the theme files and changing the coding. I have not hunted down what would need to be changed, but I am trying to make as minimal changes to the original theme as possible (to make upgrades easier).


#7

Yes exactly you are right Eric. With previous version of the theme I was able to get rid of it with CSS but the above suggestions and CSS doesn’t do anything anymore.

This is very frustrating and a very pointless change that was made. Having that icon is pretty dumb.


#8

Well, yeah. I get it. I’m just learning about how to use SVGs. It seems like they could have done it differently, but I am not sure. But the whole change was to facilitate using SVG icons instead of font icons. It’s supposed to be faster.

Like we already mentioned, it seems the way they implemented the SVGs, it’s a code item and not a CSS style so it moves it into the code. You can hide it, change the size and color, but you cannot change it.

Until I can find a better solution, I’ve just hidden the icons. I also noticed that most of the icons are not globally not positioned correctly. I adjusted that using some CSS as well.


#9

Hi.
I think there should be a “Normal post type” option, selectable in ‘Post format’ menu, in ‘Jupiter Post Options’, at the bottom of the post editing page…

Infact posts are now supposed to be image or video or audio, portfolio, twitter an so on…

NO WAY to have a normal, common, old fashoned, lovable, simple “text and images” content post!!!

Is there possibility to suggest it to the authors?


#10

I added custom CSS to a few pages and this code worked for me.

.post-type-badge { display: none; }


#11

This worked for me too, Dan. Thank you very much!