How to remove fonts?


I downloaded a demo for my Jupiter X website and it had two fonts selected in the Customizations -> Fonts&Typography . I removed these fonts and I selected two different fonts for the website.
Now, since the measuring website speed tools point at the problem with the weight of my fonts (it takes 50% of weight of the whole website) I started to dig, what’s going on. I found that the fonts that I removed in the customization are still loading inthis file.

  1. How can I remove them?
  2. How can I remove the styles of the fonts of my website that I NEVER use, like Italic weight 900?
  3. Can I somehow totally remove this fonts file that comes from “Fonts&typography”? I could add only the fonts that I use in additional css.
  4. Is there a different way to optimize it?
    Link to the website



Hey Beata!

Nice site BTW and the performance on the site is not too bad. Good work there.
I always call our fonts locally and never use the inbuilt feature or even Typekit fonts that way.
Can you paste a screenshot here of your font selection in the Theme Options?
I want to see your selections there.

Also, sometimes plugins call their own fonts too – just to rule that out, can you check that none of the plugins are calling their own fonts? I know Elementor in your case is making at least 2 calls.
See if there are others too.
You are loading about 600KB of fonts! I think you could get it down to 150KB max and then performance gains would be amazing!

We are running a Woocommerce setup with Jupiter, WP Rocket and proper hosting. The results are good. We can get a lot more out of it though. Here are the results -

In your case too, I think there is a lot more you can still get out of your setup.

I hope this helps.


Hey, thank you for the answer. I am glad you like my website.
I attache the screenshot you asked for.

I remember that the fonts which are still loading were used in the previous demo, but maybe they are somewhere else.

How can I check if a plugin calls its own font?

For a test I just unselected the two fonts in the theme customization. The look of the website changed of course but in the source code the google fonts file didn’t change, it still loads Montserrat, Space Mono and Rubik from the previous demo.

Thank you!


I also have like 521 KB of Fonts loading which takes up 50 requests (44% of the total requests). Is there someone from Artbees who could help us with this, please?


I managed to do something about it.
I use Autoptimize plugin, there is an option to tick “remove the google fonts”.
After that, I added a function in the functions.php to remove fonts loaded by elementor.
Next, I loaded fonts locally with the instruction from this article and now it’s way better :slight_smile: