How to get a high pagespeed score


#1

Dear support team,

you offer jupiter theme as a very fast theme which can get high pagespeed score. I have no luck in getting a high pagespeed score.
On the other hand all of your themes demo sites have a horrible pagespeed score.
Is there a how to or any advice which plugins I should use, which settings, ect. to get a high score and a very fast loading site ?

Many thanks for your help…

Best Regards,
Markus


#2

Hello,

Having a slow website is a common problem that many website owners have. There are some tips for this problem which will help to speed up the website:

  1. Go to Jupiter > Theme Options > Advanced > Speed Optimizations. Try to enable some option there, since it’s a beta function, it could cause some unexpected problem to your site, but you can try to combine these options to get the best fit for your site.

  2. Install a cache plugin like WP Super Cache > https://wordpress.org/plugins/wp-super-cache/

  3. Move to a premium host like WPEngine.com or update your current hosting plan to one with more resources

  4. Use a CDN service like CloudFlare.com

For further tips, you can take a look at the following articles:

Thank you.
Best regards,
Artbees Support.


#3

Any help from the Admin here ???


#4

Hello @Markus_Kaufmann,

Have you tried my suggestions from the previous reply?

Best regards,
Artbees Support.


#5

Sorry but I couldn’t reply because my Account was locked. I know all of these tips already it many thanks for your help.
I was looking for some special help.like how to disable the caching system of the theme through the functions.php to let wp-rocket work correctly or how to change the way the css is loading to prevent render blocking.
But many thanks anyways…


#6

You will only get the anodyne response (which of course are important and should be implemented). Some will cost you more money - my next blog is going to about the real costs of a good website) but this does not address your excellent point about the demo pages. Have the Artbees team not taken their own advice? DOI enfant terrible


#7

gzip compression in .htaccess as well as leverage browser caching.

ENABLE GZIP COMPRESSION

AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/xml
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE application/xml
AddOutputFilterByType DEFLATE application/xhtml+xml
AddOutputFilterByType DEFLATE application/rss+xml
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE application/x-javascript

ENABLE GZIP COMPRESSION

and

LEVERAGE BROWSER CACHING

ExpiresActive On ExpiresByType image/jpg "access 1 year" ExpiresByType image/jpeg "access 1 year" ExpiresByType image/gif "access 1 year" ExpiresByType image/png "access 1 year" ExpiresByType text/css "access 1 month" ExpiresByType application/pdf "access 1 month" ExpiresByType application/x-javascript "access 1 month" ExpiresByType application/javascript "access 1 month" ExpiresByType application/x-shockwave-flash "access 1 month" ExpiresByType image/x-icon "access 1 year" ExpiresDefault "access 2 days" ## LEVERAGE BROWSER CACHING ##

Please note that the titles you see in huge are because of # twice before the text and after the text.

These as well as caching (static, dynamic, and memcached).

I do have to admit though that combining css and js doesn’t always work. There are always some that are left behind, which are part of the theme.

I managed to get 90+ score with loading time of 700 ms. I’m using Siteground hosting as well, which would have been impossible with my account at Bluehost.

Hope this helps!!


#8

Hi Paul,

thanks for your help. These are all things I have done before. My hosting is a Server with 16GB RAM, SSD plus SSD-DB, I have installed http/2 on the Server and so I don’t do compression and minification through htaccss.
I also don’t combine js and css files because http/2 could load all in parallel - you don’t have to matter about number of requests anymore.
I get a pagespeed score of 80-95 - depending on the template and the size of the images I use but the loading time (in pingdom and GTmetrics) is between 2,4 and 6 seconds which is far away from being good.


#9

@Markus_Kaufmann did you fix this issue? I will be using WP Rocket very shortly and was wondering how it played with Jupiter.


#10

WP Rocket works great with Jupiter now.
Just disable JS minify/concatenate on WP Rocket.


#11

@Zeljko_Lazic what settings are you using for WP Rocket? I find that most of the options have to be turned off in wp rocket in order for the website not to break.

@Markus_Kaufmann any news? I am getting less than 1 s load times with wp rocket and varnish.


#12

You wont get much help outside of the theme control panel from the Jupiter support team. their a sales team after all…
my recommendation would be to go to wordpress developers on stack exchange portal for advice.


#13

Hi folks,

I was testing a lot and my favorite combination which is blazing fast (800ms) is:
jupiter: disable minify css and js but leave the other speed options checked
install and enable “cache enabler” plugin (instead of wp rocket) with minify html and js option set and set all checkboxes
install and activate autoptimize plugin and just check “optimize html-code” and "optimize javascript code"
and also under “expert” tab:
-load google fonts asynchonious
-preload fonts.google.com and some trackers or install pre-party plugin and let i preload automatically
-remove query strings
-remove emojis

I hope it helps. Tested with pingdom tools and with GTMETRICS from a server in sveden (nearest to germany).

Best Regards,
Markus