Fatal error: Can't use function return


I’ve just installed jupiter on a site and I get this

Fatal error: Can’t use function return value in write context in thepaddywagonpub.ca/wp-content/themes/jupiter/dynamic-styles/global/header.php on line 346 …

so I went into the line

345- if ( get_post_meta( $post_id, ‘logo’, true ) && ‘false’ !== $local_override ) {
346 - $logo_width = ! empty( get_post_meta( $post_id, ‘logo_width’, true ) ) ? get_post_meta( $post_id, ‘logo_width’, true
) : ‘’;

why am I getting that on a new update of jupiter…



Seems you’re using low PHP version on the server. It should be at least 5.6 version.
Please ask your hosting provider support to update PHP version for you.

Best regards,
Artbees Support.



I am experiencing this same error message when updating from 5.9.4 to 6.0.2. After uploading the new theme I can access the wordpress admin section but not the site its just a blank white screen. When debugging I get ‘Fatal error: Can’t use function return value in write context in D:\WebSites\maitlandevents.com.au\wp-content\themes\jupiter\dynamic-styles\global\header.php on line 346’

I have Mysql 5.7.16 on the site. I am running latest version of WordPress 4.9.1.

Is there a fix for this? Any idea what would be causing it?

Kind Regards,



Update: I was able to successfully downgrade to Jupiter 6.0.1 and it is now working. Must be an issue with 6.0.2.


Where did you find the install file for 6.0.1? I am having the same problem.


yes downgrade solved problem


you can downgrade from dashboard-> jupiter-> control panel ->update


I was originally asking because I was upgrading from 5.X.X and didn’t want to upgrade to 6.0.2 to be able to access the downgrade option. I now have had to stop upgrading sites until this is resolved.

I spent 5 hours Friday trouble shooting these upgrades. When I would upgrade to 6.0.2 then downgrade it would break all of my custom css, which is strange because all of my css files in my child theme and else where seemed to be in tact.

Can someone from Artbees let me know when this is fixed?


I just shat my fucken pants over this. Jesus, this needs a fix Artbees.


+1 Please fix ASAP!!



Please make sure your PHP version is at least 5.6 or higher.
It’s a requirement for Jupiter theme. You can check the PHP verison in wp-admin panel in Jupiter > Control Panel > System Status. If it’s 5.4 or lower, ask your hosting provider support to update PHP version.

Thank you.
Best regards,
Artbees Support.