ELEMENTOR is STUCK


#1

1- Elementor is stuck after installing JUPITER X
2 - Cannot roll back since ELEMENTOR says it needs the latest version to use the PRO


#2

Have you tried version control in Elementor?


#3

Hi Sagar,

If you have access to your files, simply rename the wp-content/plugins/elementor/ and then you will be able to access to your backend again. Then remove Elementor totally and update your theme, and all the plugins, after that from Jupiter X -> Control Panel -> Plugins perform the Elementor installation and your issue will be resolved.

Regards


#4

Thanks - Seems like it works now, without making any alternatives.

I read somewhere that it has to do with PLUGINS from JET.

One more thing -

  1. Having a difficult time editing PRODUCT PAGE. The text sizes are not correlating to the changes done VIA JUPITER X control panel. It appears at times but later changes back to some different sizes and color.

  2. I was planning to get one of those SIX templates that were shown in the website demo, but those things are not similar. Anything I am doing wrong ?

  3. What is the best practice to make these pages. In the JUPITER X tutorials, it suggest doing via woo-commerce- JET template, or directly via CONTROL panel ? I found that doing this VIA Elmentor is the not the best practice.

THanks