Elementor Editor wont load when Jupiter X is active


#1

Hey there,

The Elementor Plugin editor works fine by itself. But once I activate Jupitor X, it makes Elementor hang indefinitely on the loading screen. I’ve also tried deactivating all plugins except Elementor, but it still didn’t load the editor.

Version number: Version: 1.0.0-beta1

File Attachment(s):
I recorded a screenshot video for you –
https://drive.google.com/open?id=1qG_-5VJOph3l7w6tETTd4agG_QZl1xM8

Thanks :slight_smile:


#2

I am having this same problem!


#3

Hi,

Kindly enable debug mode by adding define( ‘WP_DEBUG’, true ); to your wp-config.php file to check if any errors are visible.

Regards.


#4

I got it to work by going to Elementor<Settings<Advanced<then enabling Switch Editor Loader Method. I found the solution here.


#5

I turned on debugging in the wp-config.php file and re-activated the theme.

I created a new page to test elementor and it just worked out of the blue.

And no bugs. So weird.

Over the weekend Elementor promted an update so I’m thinking that update may have solved the conflict with the beta on it’s own?

Either way, it works now :slight_smile:


#6

Glad to hear it, thank you.