Elementor 2.4 not compatible with Jupiter 6


#1

Elementor worked fine with Jupiter 6 until it was updated to 2.4 and up

I know the focus is on Jupiter X , but I wonder will this get resolved for J6?

Thanks guys


#2

We have actually not tested it with Jupiter 6, so I am not sure if it will get resolved anytime soon.
If you want to use Elementor, why not go for Jupiter X then?


#3

Heya! yes I am setting my site up with Jupiter X

But my live site is Jupiter 6 until completly ready to go live with Jupiter X

I actually swapped to Elementor back in September , as I was tired of WP Bakery


#4

Hi Luke,

Thanks for reporting. We will check this and soon provide a solution for it.

Regards


#5

Cool thanks

Elementor worked 90% with J6 - just some font colour issues , but other than that it was pretty good.

When Elementor 2.4 came out it started to free the page builder when opening. But I have noticed this happening with many other themes , as reported by Elementor Community on FB


#6

Should I raise a ticket with my login details to help investigate?


#7

No need to. The task for compatibility check is already created and added to the next sprint. We will fix this as soon as possible. For now, please keep the old version. thanks.


#8

We have tested the issue on a couple of websites and couldn’t replicate it. Are you sure you don’t have Elementor Pro and the issue is not happening due to the Elementor Pro mismatch with the basic version? It can also be a plugin conflict. Anyway, we have tested and couldn’t find any issue with Elementor and Elementor Pro and Jupiter v6.1.6 and WP 5.0.3


#9

Thanks Mohsen ,

I have raised several tickets with Elementor , yes I have Pro and basic version , but they said it was template related.

I raised Ticket ID is 87966 - if you can take a look I would be super grateful ,

Thanks


#10

I have deactivated Elementor pro and then updated Elementor basic to 2.4.5

But the page builder still does not load.

If you could have a look at the ticket above and offer a solution I would be super grateful


#11

Hi Luke,

I just checked your ticket, the credntials were wrong. Can you check them? Also, did you change the rendering options in Elementor -> Settings?


#12

Thankyou thank you thank you

Yes this has fixed the issue , by switching from child theme , to parent and then back again

I can now used Elementor 2.4.5 with Jupiter 6 - thanks so much


#13

Glad to hear that :slight_smile: