Editing Portfolio Page (not single post) /portfolio/


#1

How do you do it?

The slug is /portfolio for the “archives” but I can’t edit this page

The portfolio posts are in /portfolio/portfolio-post which are editable and fine.

I can’t create a custom page with the slug portfolio however. This is problematic…

Any ideas? Thank you in advance.


#2

Well, this is the default archive page that automatically takes the layout and unfortunately, there is no option to edit this page.

Creating a new page using the same slug will actually require you to disable the archive for the Portfolio post type.


#3

It worked in Jupiter?

Will the portfolio single posts slugs now follow the convention of this new slug?

This means creating redirects for dozens of portfolio items as well as generally bad grammar and seo.

Must be a way around this.


#4

May be you can try changing the slug.

To change the Portfolio slug, you can use the below code at the bottom of functions.php file in child theme.

add_filter( 'register_post_type_args', 'wpse247328_register_post_type_args', 10, 2 );
function wpse247328_register_post_type_args( $args, $post_type ) {

	if ( 'portfolio' === $post_type ) {
		$args['rewrite']['slug'] = 'portfolios';
	}

	return $args;
}

Then, go to WP Dashboard -> Settings -> Permalinks and save changes without editing anything. This is to refresh the permalinks so that the new changes take place.


#5

I think what I need to do is the first suggestion of this - I’d like to disable the archive so I can use my own /portfolio archive page. I’m using the older Jupiter.
At the moment it grabs some kind of weird default styling. Originally I found changing the slug for the posts
works as you indicated, but then all my portfolios have a new url rather than just portfolio/portfolio page name. I don’t want to have to setup a whole heap of redirects from the old site where the urls are already live, would rather fix this one page!

Are you able to help with a way to disable the auto-archive or rename the auto-archive so that it isn’t called and my custom page with grid etc layout is?

Thanks! (edited after rereading above replies)


#6

Could you please go to config.php file present in jupiter/framework/custom-post-types folder.

Go to line 444 and you will see this code:
'has_archive' => true,

Set it to 'has_archive' => false,

Let me know if this helps.