Content flickers while scrolling in Jupiter 6 on Chrome


#1

The issue of content flickering while scrolling has been reported recently.

The issue is happening in Jupiter 6 with the latest Chrome version which is 73. It seems like Chrome has changed something which is triggering this issue.

To solve this issue for now,

  1. Please go to Jupiter -> Theme Options -> Advanced -> Speed Optimizations and disable the Minify Theme Javascript Files option.

  2. Please go to Jupiter -> Theme Options -> Global Settings -> Site Settings and disable the Smooth Scroll option.

We would be glad to receive any feedback.


#2

#3

Im having the same issue with Jupiter x how can I disable smooth scrolling ?


#4

@Danish_Iqbal Hi. I’m also getting bad flickering in Jupiter X in Firefox mobile. I can’t find either of those options. How can I fix it please?


#5

@Danish_Iqbal @Fredy_Hernandez Hi, just wanted to let you know that I got rid of the flickering from Firefox and Chrome on Android by:

  1. Changing the header from Sticky to Fixed
  2. Toggling to ON the option “Enable on Mobile” (for the fixed header)

Best regards,
Luke


#6

The issue has been reported and it will be fixed in the next update.

For now, you can use @Luke_Farrugia solution.


#8

Any updates on this? Is there a scheduled date for the version update?

Best regards


#9

Here’s possible fix for Jupiter X: Flickering when scrolling


#10

So jupiter 6.2.0 has been released and I’m confused. There is no mention of this bugfix anywhere; yet we have a dev who said on the 22nd of April that it will be fixed in this update. Do we still have a half functioning theme that needs a number of it’s settings disabled to work properly or can we start re-activating things again?


#11

#12

Had the same issue. upgraded to 1.5.0 and seems to have been solved!


#13

This is not fixed in Jupiter 6.2.0. We are still waiting for a solution.


#14

You’re on the wrong forum mate. Post this to Jupiter X - You’ve come to talk to the second class customers here; the ones with Jupiter 6.2.0


#15

Soooooooo… Is the fix ever coming…?


#16

I’m also wondering about this? Any response from artbees? :frowning:


#17

Since it’s like no one at Artbees will fix this issue in Jupiter 6 and the solution posted on top also disabled features like parallax in sections, I searched for a workaround myself and came up with something which at least looks promising: judder and warnings are gone and parallax is still working.

Add this snippet to the custom JS Option of Jupiter:

jQuery(document).ready(function() {
    if (window.SmoothScroll) {
	    window.SmoothScroll.destroy();
	    console.log('Disabled smooth scrolling to prevent stutter.');
    } else {
	    console.log('Could not prevent smooth scrolling, since object was not ready.');		
   }
});

Hope this helps. Also if I’m missing something here or there are other suggestions, please post them!


#18

Thanx Andreas_Schneider.
It works for me.