Cannot edit published pages with Elemtentor


#1

I purchased Jupiter a while ago (2017?) and set up a development page. I created/edited some paged back then and everything seemed to work. During the last 12 month I didn’t had the time to work on a new page. Today I logged in, updated Wordpress and all plugins. I get everything to work except that I cannot edit already published pages. Everytime I try to edit pages with Elementor I get the same error:
“Sorry, the content area was not found in your page”.
When I toggle the page back to draft mode, I can edit the with Elementor just fine (until I publish it again).

FunFact: this doesn’t happen for the start page. I can edit the start page even when it’s published.

Any ideas?


#2

I just did a complete fresh installation of Wordpress/JupiterX. I installed all the necessary plugins and most of the recommended plugins. Then I imported a template. Same problem. Whenever I try to edit a page with Elementor I get the same error:

“Sorry, the content area was not found in your page.
You must call ‘the_content’ function in the current template, in order for Elementor to work on this page”

I activated JupiterX, but haven’t changed any JupiterX, Elementor or Theme/Plugin setting. No custom content where added (just the stuff from the template installation).

JupiterX System status looks fine (PHP & WP memory limit set to 265MB)

Wordpress 5.2.3
JupiterX v1.10.0
Elementor v2.7.1


#3

Also tried to deactivate all plugins but JupiterX Core, Elementor and ACF. Didn’t helped.
Also tried different browsers to rule out caching and/or javascript problems. Also didn’t helped


#4

Seems like I found the reason for this problem: a configuration issue in our nginx.

The “$args” parameter was missing:

location / {
try_files $uri $uri/ index.php$args;
}