Advanced Google Maps not working


#21

Same here and afraid to touch anything since I 404d my dev site to migrate. Have a backup and a broken live site now.


#22

Same here… and i dont have this file? I just got scripts.js…

Update from Artbees?


#23

Can we please get an idea on when this update is supposed to be released, Artbees??


#24

while not a perfect idea, did anyone consider buying a different google map visual composer plugin for like 15$ on envato? I’ll prob end up doing that when my next site launches if I run into this problem. goodluck eveyone.


#25

generate api key in
console.developers.google.com/apis/ and give permissions for your domain. after that
editing file in wp-content/themes/jupiter/components/shortcodes/mk_advanced_gmaps/mk_advanced_gmaps.js
replace
https://maps.googleapis.com/maps/api/js?callback=MK.api.advancedgmaps
with
https://maps.googleapis.com/maps/api/js?key=MYAPIKEY&callback=MK.api.advancedgmaps


#26

It worked perfectly…
thanks


#27

for me there’s any way to make this hook work…

the error is always the same, also with a dedicated plugin with a specific option to insert the google map api key…


#28

while waiting for the official fix open mk_advanced_gmaps.php and add your apikey in the options array to make the script use it

$json['options'] = array(
  'apikey'        => 'YOURAPIKEY'

#29

Just found the solution.
The reason the advanced google maps isn’t working is due to a google maps API key.

If you go to theme options, general, global settings, then scroll down right after smooth scrolling and right before image resize quality you should find Google Maps API Key.

Follow the instructions and generate a API key.
You should now find that you advanced google maps will appear.

All the best,
Ashen


#30

Anyone got a solution for this. All the solutions mentioned here didn’t work for me :frowning:


#31

Thanks, Ashen! That worked. Wonder why the initial API key disappeared…

P.


#32

Thank you Ashen! Your solution also worked fot me :clap:


#33

Thanks a lot as well, Ashen…
I never would have had the idea to look in that direction…
Cheers


#34

None of the solutions worked for me… :frowning:


#35

Thanks to Ashen for solving this one!


#36

Thank you Ashen.
But there is a problem with google API settings, atleast in my case.
It does not work for me until I set URL for exact page where google map is placed.
First I set domain in API’s credential e.g. http://mydomain.com/, but it didn’t work, than I
set exact URL to the page that I use for google map, http://mydomain.com/?page_id=123 and that works.

Cheers :slight_smile:


#37

you have to do this :
.mydomain.com/


#38

with asterisk before and after *


#39

@Achard

Thank you. I did not know that trick with asterisk.


#40

If you are using Version 4, you can open file “/wp-content/themes/jupiter/shortcodes/mk_advanced_gmaps.php”.
Then edit this line:

$output .= '<script src="http'.( is_ssl() ? 's' : '' ).'://maps.google.com/maps/api/js?sensor=false" type="text/javascript"></script>';

TO

$output .= '<script src="http'.( is_ssl() ? 's' : '' ).'://maps.google.com/maps/api/js?key=[Your API KEY]" type="text/javascript"></script>';

Good Luck!