Advanced Google Maps not working


#1

Hello. Just recently, the Advanced Google Maps component has broken. Here is the message I’m receiving:

This page didn’t load Google Maps correctly. See the JavaScript console for technical details.

Any help would be greatly appreicated. Thank you.


Advanced Google Maps API Fix Needed
#2

It seems this is a problem with Google now requiring you to have an API key. I got one but cannot find where to place it in the Jupiter map component. Anyone? Could really use some help. Thanks.


#3

I’m having the same problem!!!


#4

Same problem here, I raised a ticket last week and was told that they are working on a fix, but I had no indication on how long that would take.


#5

I’ve had to replace with the standard google embed code. A bit ugly but at least a map is there.


#6

I have the same problem! Someone got a answer?


#7

Any news from artbees? We need to make the map working asap.


#8

Haven’t heard anything from them and I have no idea how to contact them. This is pretty frustrating, as I have a client who is not happy about the map being broken. Does anyone know how to contact Artbees?


#9

Hey,

i´ve got the same problem. Yesterday I tried to include the advanced map, but it doesn´t work.
For less than 1 second i can see the map into the frontend of my website, than the error is shown.
If I refresh my browser there is the same procedure.

I´ve generated the required API (like the JS console told me). But nothing changes.


#10

Apparently this will be fixed in the next update.


#11

Is there any eta on when “the next update” will be available? Is there a temporary workaround for this problem right now?


#12

Hi,

I fixed it by changing this in /wp-content/themes/jupiter/assets/js/min/components-full.js:

https://maps.googleapis.com/maps/api/js?callback=MK.api.advancedgmaps

TO:

https://maps.googleapis.com/maps/api/js?key=YOUR_API_KEY_HERE&callback=MK.api.advancedgmaps

Then I also had to turn off “Intelligent Components Technology” in the theme options under advanced. <<< not sure why

This is a bad fix, but it’ll work while we wait for an update…

Good luck.


#13

Hi Tobias,

thanks for helping us to fix it since the artbees have a solution.

Great! :slight_smile:


#14

Hi! I tried this but it didn’t work. Do you think it is because I did it within the child theme instead?

Also, I am doing this on a multi-site.


#15

Sorry, I have no idea :confused: Have you cleared the theme cache?

It would be nice to get an answer from an Artbees employee on this.


#16

I went and made the changes in the main theme and it worked. Strange but thanks so much for posting this fix! Hope they fix it soon.


#17

Thanks for posting the fix, Tobias. For some reason, though, I do not have the components-full.js file in that directory. I only have a file called core-scripts.js. Any idea why you guys would have this and I wouldn’t?

Artbees - Please get on this quickly. Have several unhappy clients at the moment because of the lack of map.


#18

Are you using an older version of the theme? The fix should be the same, but it’s probably in a different file.
You’ll have to figure out what file the google maps api is being loaded from and add your api key like I’ve shown above.


#19

I’m having the same problem!!!


#20

Same problem!!! any ideas