Advanced Google Maps element zooming issue


#1

Problem:
Zooming issue with the Advanced Google Maps element in Jupiter theme.

WHY?
It seems Google has changed something in the Maps API due to which the Advanced Google Maps element is having issues with zooming.

How to solve:
Assuming you are using Jupiter 6.1.1
Please do not adapt to this solution if you are not using Jupiter 6.1.1

  1. Copy the contents of this file https://gist.github.com/danishiqbal4/26b45b741f33655b5c4a8f4ec9155575

  2. Edit components-full.6.1.1.js file present in wp-content/themes/jupiter/assets/js/

  3. Paste the contents of the file copied in step 1 into components-full.6.1.1.js file.

  4. Now open the WordPress dashboard, go to Jupiter -> Theme Options -> Advanced -> Speed Optimizations and DISABLE the Minify Theme Javascript File option.

That’s it…!

Purge the plugin cache (If using any cache plugin)
Clear the browser cache and voila…!

Permanent Fix:
The permanent fix of this issue will be released in the next update that is Jupiter 6.1.2

Update:
We have already released the fix in the Jupiter update 6.1.2
Please update your theme.


Advance Google Maps Zoom Issue
#7

Why using the latest version of maps api ?
It would have not happened if you were using a fixed version.

So instead of this :
https://maps.googleapis.com/maps/api/js?"+apikey+"callback=MK.api.advancedgmaps
You could use this :
https://maps.googleapis.com/maps/api/js?v=3.1&"+apikey+"callback=MK.api.advancedgmaps

in full-script.js present in wp-content/themes/jupiter/assets/js/min
Therefore you don’t have to disable the minify theme javascript file option

So for people using Jupiter 5.9 like me you can use this solution.
I only tried the v3.1 and it works but didn’t try newer versions.


#8

thanks clement. i will try this.

artbees support: you should also post a fix for jupiter 5.9, because i have serveral sites with 5.9.7 and i will not update them now, because i see that a lot of people have problems with updating to jupiter V6


#9

Thanks for this stop-gap fix!


#10

Worked like a charm, thank you


#11

@Adrienne_Grace @James_Diaz1

You can now update the theme to 6.1.2 as the fix has been released.

Thanks.


#12

Thank you for your solution.

I think it is better to always move forward and use the latest versions available because of the obvious reasons. :smiley:

Thanks again.


#17

Where is the KEN Theme Fix description?


#18

Still broken on 6.1.3…


#19

More info on this - if you have multiple markers the zoom still doesnt work


#20

Here you go http://forums.artbees.net/t/google-maps-element-zooming-issue-with-the-ken-theme/

Thanks.


#21

It will be fixed in the next update.

Thanks.